Wufoo is down
Incident Report for Wufoo
Resolved
This incident has been resolved.
Posted Aug 10, 2022 - 19:18 PDT
Monitoring
We're releasing a fix and are currently monitoring the site.
Posted Aug 10, 2022 - 19:12 PDT
Identified
Wufoo is currently down. We have identified the issue and are working on a fix.
Posted Aug 10, 2022 - 17:53 PDT