All Wufoo Services Down
Incident Report for Wufoo
Resolved
This incident has been resolved.
Posted Mar 26, 2019 - 15:14 PDT
Monitoring
Services are back up and running, we will continue monitoring the status of our services as we investigate the root cause of the issue.
Posted Mar 26, 2019 - 15:09 PDT
Update
All services are back up and running, but may be experiencing degraded performance.
Posted Mar 26, 2019 - 15:04 PDT
Investigating
We are currently investigating this issue.
Posted Mar 26, 2019 - 15:00 PDT
This incident affected: Forms and Administration, Mobile Admin, API (v3), and Notifications.