Issues with logging in to Wufoo
Incident Report for Wufoo
Resolved
This issue has been resolved.
Posted Apr 24, 2024 - 14:18 PDT
Identified
We have identified the issue and are working on implementing a fix.
Posted Apr 24, 2024 - 13:35 PDT
Update
We are continuing to investigate this issue. Using an alternate browser may continue to be a workaround for customers experiencing intermittent login failures.
Posted Apr 24, 2024 - 12:50 PDT
Investigating
We've identified an issue impacting Wufoo login, where users will see a "password incorrect" message erroneously. Some users have reported that using the Firefox browser resolves this issue for them. We are investigating and will provide further updates as we have them.
Posted Apr 24, 2024 - 09:53 PDT