Degraded Performance for Email Notification-Enabled Forms
Incident Report for Wufoo
Resolved
This issue has been resolved.
Posted Nov 12, 2018 - 20:39 PST
Identified
We have identified a potential issue with forms that make use of email notifications. We are working to resolve this issue at this time.
Posted Nov 12, 2018 - 19:59 PST