Wufoo Emergency Maintenance
Incident Report for Wufoo
Resolved
This incident has been resolved.
Posted Sep 13, 2021 - 17:33 PDT
Identified
Select outbound integrations may experience issues during this incident.
Posted Sep 13, 2021 - 17:18 PDT
This incident affected: Forms and Administration and Notifications.